:::: MENU ::::

Mikrotik opcje dhcp 43 i 46

środowisko: RB1100AHx2 RouterOS ≥ 6.33.5

Czasem dla maszyn pobierających informacje o ustawieniach sieciowych poprzez protokół dhcp chcemy wyłączyć netbios (opcja 43) lub np. przesłać adresu IP kontrolera wifi (opcja 46). Poniżej informacja jak dodać tego typu opcje na serwerze dhcp działającym pod kontrolą RouterOS.

46 – wyłączamy netbios

w tym celu ustawić należy opcję o kodzie 46 serwera dhcp na wartość 2 (netbios node-p)
/ip dhcp-server option add name="nb-node-p" code=46 value="2"

następnie wyświetlić listę podsieci serwera dhcp aby sprawdzić numer podsieci dla której włączona zostanie zdefiniowana powyżej opcja
/ip dhcp-server network print

dla wybranej podsieci włączyć opcję 46 (w poniższym przykładzie dla podsieci o numerze 0)
/ip dhcp-server network set 0 dhcp-option="nb-node-p"

43 – adres IP

należy przekształcić zapis dziesiętny adresu IP na adres w zapisie HEX np adres 192.168.100.10 to HEX C0A8640A, wartość pola dla kodu 43 tworzymy 0x0104+IP_HEX czyli w tym przypadku 0x0104C0A8640A
/ip dhcp-server option add name="wifictrl" code=43 value="0x0104C0A8640A"

następnie wyświetlić listę podsieci serwera dhcp aby sprawdzić numer podsieci dla której włączona zostanie zdefiniowana powyżej opcja
/ip dhcp-server network print

dla wybranej podsieci włączyć opcję 46 (w poniższym przykładzie dla podsieci o numerze 2)
/ip dhcp-server network set 2 dhcp-option="wifictrl"